Timestamps on folders, again.. ;-)

  • updated
  • Resolved


Since nobody else seems to have the same problem as I regarding updating time stamps on folders, I wonder if someone can tell me what I might be doing wrong…

I have the Pro version of TeraCopy 3.8 on a Windows 10 (latest version).

I also have the source data on an external HD connected by USB-C to my computer, and the destination on a locally connected NAS through Ethernet.

When I make a new copy of the data from the external drive to my NAS, I seems to work (at least when I do not copy to many folders at the same time).

But the thing is that a have around 30TB of data that TeraCopy was not able to update the folders time stamp on. So therefore, I tried to copy it again without any success, I have also tried to copy smaller amount of data and tried to only copy the folders again, but still no success.

I have options set to "Keep Folder Timestamp".

I know that TeraCopy have the correct time stamp on the folders in its database, but it does not update the destination folder.

So in short, it works when making a fresh copy, but it does not work when I try to overwrite a copy on the destination folder.

Is there a way to force TeraCopy to set the timestamp on folders that already exists? Or what I am I doing wrong???

If "Code Sector" reads this, can you please explain the process "behind the scenes" when TeraCopy shall apply the timestamps, it might help me/us figure out what has been going on with this if there is a bug.


robert h

@Jeff, Whatever you did when it comes to setting the time stamp on folders with update 3.8.2, it now works for me too. Thanks!

Code Sector
  • Resolved

Good to hear, thanks for the confirmation.

 Commenting is disabled